Excel Formel - Summenprodukt statt Summewenns Funktion

Diskutiere und helfe bei Excel Formel - Summenprodukt statt Summewenns Funktion im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo, nach meiner Internetrecherche habe ich zumindest herausgefunden dass ich eine Summenprodukt Formel anwenden muss, statt der Summewenns... Dieses Thema im Forum "Microsoft Office" wurde erstellt von CarolineG16, 8. April 2021.

  1. Excel Formel - Summenprodukt statt Summewenns Funktion


    Hallo,


    nach meiner Internetrecherche habe ich zumindest herausgefunden dass ich eine Summenprodukt Formel anwenden muss, statt der Summewenns Funktion, weil keine #Werte angezeigt werden, wenn die Quelldatei geschlossen ist.


    Trotz all meiner Bemühungen, schaffe ich es nicht diese Formel zu schreiben, bzw. bin mir nicht mehr sicher, ob sie für meinen Fall Anwendbar ist.


    Der Fall ist folgender:


    Ich habe in der wiedergebenden Datei eine Reihe von Kundennummern, denen ich einen summierten Wert als Zahl von einer anderen Datei wiedergeben möchte. In der Quelldatei sind die selben Kundennumer enthalten, aber in vielfacher Ausführung mit dazugehörigen unterschiedlicher Planzahlen, die ich dann summieren möchte.


    =summewennssummenbereich; Kriterien Bereich 1; Kriterie 1


    Wie kann ich die Formel jetzt umschreiben, so wie ich verstanden habe, multipliziert die Summenprodukt Funktion, das ist aber nicht was ich möchte.


    Vielen Dank und Viele Grüße


    Caroline
     
  2. Claus Busch Win User

    Verknüpfungen in externe Dateien

    Hallo Yannik,

    aus einer Formel kann ich wohl keine Firmeninterna auslesen.

    SUMMEWENN funktioniert nicht bei geschlossenen Dateien. Ändere die Formel um auf SUMMENPRODUKT.

    Claus
  3. Claus Busch Win User

    Excel~

    Hallo,

    dann SUMMEWENN(BereichGrund;C3;BereichBetrag)+SUMMEWENN(BereichGrund;C4;BereichBetrag)....

    Oder nehme aus der SUMMENPRODUKT-Formel in meiner Tabelle den Teil mit dem Datum raus und passe die Bezüge an.

    Claus
  4. Claus Busch Win User

    Excel Bug bei Summewenn und Zahlen

    Hallo Markus,

    Excel rechnet mit 15 Stellen Genauigkeit. So werden dann längere Zahlen ab der 15. Stelle mit Nullen aufgefüllt. Das führt bei der Berechnung dann zu diesem Fehler. Aber es gibt ja Alternativen, die korrekt rechnen:

    =SUMMENPRODUKT(--(A2:A18="00010003002000230024");B2:B18)

    oder

    =SUMME(WENN(A2:A18="00010003002000230024";B2:B18;0))

    Diese Formel ist eine Array-Formel und die Eingabe muss über STRG+Shift+Enter abgeschlossen werden.

    Du kannst bei dir auch gleiche Stellen durch Platzhalter ersetzen, dann funktioniert auch die SUMMEWENN-Formel:

    = SUMMEWENN(A2:A18;"*"&"10003002000230024";B2:B18)

    oder

    = SUMMEWENN(A2:A18;"*"&"3002000230024";B2:B18)

    Mit freundlichen Grüßen

    Claus
  5. Claus Busch Win User

    SUMMEWENN mit Jahr aus kompletter Datumsangabe

    Hallo,



    am einfachsten ginge es, wenn du eine Pivot-Tabelle erzeugen würdest und darin dann das Datum nach Jahr gruppieren würdest.

    Willst du es mit Formel machen, verwende Summenprodukt, denn du musst auf das Jahr, also nur einen Teil des Datums zurückgreifen:

    =SUMMENPRODUKT(--(JAHR(A1:A1000)=2012);B1:B1000)

    oder du machst es mit Summewenns:

    =SUMMEWENNS(B1:B1000;A1:A1000;">=01.01.2012";A1:A1000;"<=31.12.2012")



    Mit freundlichen Grüßen

    Claus
  6. Claus Busch Win User

    "SUMMEWENNS" Formel scheint korrekt Ergebnis ist aber 0 obwohl Werte enthalten sind

    Hallo Dave,

    in SUMMEWENNS kannst du keine weiteren Funktionen wie z.B. Monat einfügen. Da gehen nur Bereiche und Werte.

    Schau hier:

    https://1drv.ms/x/s!AqMiGBK2qniTgYEHKQGZq5HmsZrltQ

    Dort ist es nun mit Summenprodukt-Formel gelöst. Allerdings habe ich auch nur 0 als Wert bekommen, da in Tabelle "Tag" für November keine Werte vorhanden sind. Am 1. November habe ich jetzt mal 3 Werte eingetragen.

    Claus
  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

Excel Formel - Summenprodukt statt Summewenns Funktion - Microsoft Office

Die Seite wird geladen...

Excel Formel - Summenprodukt statt Summewenns Funktion - Similar Threads - Excel Formel Summenprodukt

Forum Datum

Formel Summenprodukt

Formel Summenprodukt: Hallo und guten Abend, Formel liefert kein Ergebnis und auch keine Fehlermeldung. Was habe ich falsch gemacht? {=SUMMENPRODUKTRESTSPALTEC4:U4;4=0+RESTSPALTEC4:U4;4=3*C4:U4}
Microsoft Office 4. Februar 2021

Zahlenteil als Suchkriterium für SUMMENPRODUKT oder SUMMEWENN

Zahlenteil als Suchkriterium für SUMMENPRODUKT oder SUMMEWENN: Hallo Community, Ich versuche Datensätze, exportiert aus einer Buchhaltung, monatlich auszuwerten, und zwar in Abhängigkeit - von der Kontonummer - von dem Soll / Haben Kennzeichen - dem...
Microsoft Office 3. Januar 2020

Formel SUMMEWENNS

Formel SUMMEWENNS: Hallo, ich habe mit der Formel folgendes vor: in Tabelle1 habe ich Beträge ( Spalte D), Kategorie (z.B. "Gehalt" in Spalte A) ein Datum in tt.mm.jjjj (Spalte C) Ich möchte jetzt in der...
Microsoft Office 19. April 2019

Excel Funktion/Formel

Excel Funktion/Formel: Hallo, hätte eine Frage bezüglich excel 2016 zu der Formel „MONAT“ Klappt alles, bis auf dass wenn man in der Zeile kein Datum stehen hat zeigt es immer die Zahl 1 Bzw Monat Januar an....
Microsoft Office 5. Oktober 2018

Formel SUMMEWENNS

Formel SUMMEWENNS: Hallo Ich möchte aus einer grösseren Kostenübersicht alle Teilkosten "Heizung" aufaddieren. Für "Heizung" sind mehrere Kostenarten vorhanden. Ich dachte SUMMEWENNS sollte es bringen. Es...
Microsoft Office 25. Februar 2018

Excel Summewenn Funktion

Excel Summewenn Funktion: Hallo liebe Leute, Folgendes Datenblatt möchte ich berechnen: Hierzu die Frage, ob Excel bei der Summwenn keine Bedingung mit "1005*" erfüllen kann? Geht das Sternchen als Platzhalter bei Zahlen...
Microsoft Office 29. September 2017

Abbilden von "komplexer" Formel mit SUMMENPRODUKT in Excel

Abbilden von "komplexer" Formel mit SUMMENPRODUKT in Excel: Hallo Community, ich möchte eine Formel aus einem Paper in Excel abbilden, komme da aber leider schnell an meine Grenzen. Das ist die Formel: [IMG] In einer Tabelle sollen die einzelnen...
Microsoft Office 10. Juli 2017
Excel Formel - Summenprodukt statt Summewenns Funktion solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.