Komplizierte Excel-Formel

Diskutiere und helfe bei Komplizierte Excel-Formel im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo! [IMG] Ich möchte, dass wenn ich die "Zahlen" Reihenfolge eingebe aus einem manuell gewählten Bereich in diesem Fall A2 bis 4 die werte der... Dieses Thema im Forum "Microsoft Office" wurde erstellt von LE2004, 25. März 2020.

  1. LE2004
    LE2004 Gast

    Komplizierte Excel-Formel


    Hallo!


    [​IMG]

    Ich möchte, dass wenn ich die "Zahlen" Reihenfolge eingebe aus einem manuell gewählten Bereich in diesem Fall A2 bis 4 die werte der Daneben stehenden Spalte B2 bis 4 in eine Zelle mit Semikolon angezeigt wird.


    Ich hoffe mann kann verstehen was ich meine und dass es irgendeine Formel dafür gibt.


    Vielen Dank für eure Hilfe

    Leon
     
  2. Claus Busch Win User

    Komplizierte Excel-Formel

    Hallo Leon,

    das lässt sich mit einer Formel nicht realisieren.

    Probiere mal folgende UDF:

    Function TextKombi(Bereich As Range, Zahlen As Range) As StringDim varZahlen As VariantDim i As IntegerDim myStr As StringvarZahlen = Split(Zahlen, ",")For i = LBound(varZahlen) To UBound(varZahlen)    myStr = myStr & "; " & Application.Index(Bereich, varZahlen(i))NextTextKombi = Mid(myStr, 3)End Function
    und rufe diese dann im Blatt auf mit z.B.:

    =TextKombi(B2:B4;D2)

    Claus
  3. Claus Busch Win User

    Komplizierte SVERWEIS Formel

    Hallo,

    versuche es mal mit:

    =WENNFEHLER(E6+SVERWEIS(H5;L2:M8;2;0);E7+SVERWEIS(H5;L15:M18;2;0))

    Claus
  4. SandraSoXA Win User

    Excel-Formel

    Hallo Claus

    Ja, genauso wollte ich es :). Aber wie bekomme ich jetzt die Formel oder Makro in meine Original-Mappe.

    Habe es mit dem kopieren der Formel versucht, dann wird mir aber immer #NAME im Feld angezeigt :-(

    Habe es auch versucht, meine kompakte Mappe in die mit dem Makros zu kopieren, auch ohne Erfolg :-(

    Mannomann, hätte ich gewußt, wie kompliziert das ist, hätte ich besser nicht gefragt. Excel bleibt für mich ein Buch mit sieben Siegel :)

    Danke aber für deine Hilfe :) :)
  5. Claus Busch Win User

    Sortieren einer Liste mit Bedingung

    Hallo,

    damit machst du die Formel nur noch komplizierter und fehleranfälliger.

    Wenn sich die Bereiche ständig ändern, verpasse den 3 in Frage kommenden Spalten dynamische Bereichsnamen und verwende diese in der Formel. Damit greift die Formel immer auf den aktuellen Datenbestand zu.

    Claus
  6. Claus Busch Win User

    Formel für Textteile exkl. Umlaute

    Hallo Ute,

    ja, ich habe etwas zu kompliziert gedacht. Deine Formel ist um einiges kürzer und macht das auch das Gewünschte.

    Mit freundlichen Grüßen

  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

Komplizierte Excel-Formel - Microsoft Office

Die Seite wird geladen...

Komplizierte Excel-Formel - Similar Threads - Komplizierte Excel Formel

Forum Datum

Komplizierte SVERWEIS Formel

Komplizierte SVERWEIS Formel: =WENNSVERWEISH5;L2:M8;1;FALSCH=H5;SUMMESVERWEISH5;L2:M8;2;FALSCH;E6;SUMMESVERWEISH5;L15:M18;2;FALSCH;E7 Die Formel die ich dazu entwickelt habe sollte zuerst H5c zwischen L2 und M8 suchen und...
Microsoft Office 30. März 2020

Excel Formel

Excel Formel: Ich versuche mit dem Befehl =ZÄHLENWENN(C3:N3;1)-ZÄHLENWENN(O3:Z3;1) ein Ergebnis zu erhalten. Allerdings erkennt Excel den hinteren, fett markierten Teil nicht mehr als Formel. Die Werte im...
Microsoft Office 12. April 2019

Excel Wenn Formel

Excel Wenn Formel: Hi, kurze Frage: Ich würde gerne eine Formel in eine Tabelle einsetzen: Spalte A Ist-Stunden Spalte B Soll-Stunden Spalte C Die Plus- oder Minusstunden die daraus resultieren... Hilfe, es...
Microsoft Office 12. Februar 2019

Excel Formel

Excel Formel: Hallo zusammen, ich möchte wir was bauen daher suche ich die richtig Formel noch. Also ein beispiel. A80-A500 mit je daneben 6 spalten sind ausgefühlt. dann möchte ich gerne das wenn ich in...
Microsoft Office 5. August 2018

Excel Formel

Excel Formel: Hallo, Kann man eine Excel Formel patentieren lassen? kann man Sie an Microsoft verkaufen? Ich besitze eine Formel die sehr interessant ist und praktisch niemand kennt. Gruss
Microsoft Office 26. November 2017

Formel in Excel

Formel in Excel: Ich habe eine Arbeitsmappe (Kassabuch) erstellt. Für jedes Monat eine "Tabelle). Letzte Tabelle ist ein "CASH STATEMENT" das für jedes Monat separat ausgedruckt werden soll. Dieses CASH...
Microsoft Office 9. Juli 2017

Excel Formel

Excel Formel: Hallo!! Ich habe da mal eine frage. Wie bekomme ich die Formel =Wenn(F4="T";20;"");oder(F4="N";20;"") zum laufen??? bin um jede Hilfe dankbar!! MFG Matthias
Microsoft Office 4. Januar 2017
Komplizierte Excel-Formel solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.