Nutzung von Variablen beim Zugriff auf Tabellen

Diskutiere und helfe bei Nutzung von Variablen beim Zugriff auf Tabellen im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo zusammen, ich nutze in einer Formel folgende Passage: ... SVERWEIS(F25;Feiertage[BadenWürtemberg];1;FALSCH) ... "Feiertage" ist dabei eine... Dieses Thema im Forum "Microsoft Office" wurde erstellt von VolkerMader, 10. November 2016.

  1. Nutzung von Variablen beim Zugriff auf Tabellen


    Hallo zusammen,

    ich nutze in einer Formel folgende Passage:

    ... SVERWEIS(F25;Feiertage[BadenWürtemberg];1;FALSCH) ...

    "Feiertage" ist dabei eine Tabelle (keine Tabellenblatt!) in der die Feiertage für jedes Bundesland in den einzelnen Spalten eingetragen sind.
    Den Teil "BadenWürtemberg" würde ich gerne ersetzen.
    In einer Zelle (F20) soll das Bundesland geändert werden können und meine Formel soll dann in der Spalte des entsprechenden Bundeslandes suchen.

    Ich habe bereits mit INDIREKT (anstelle [BadenWürtemberg] wurde von mir [INDIREKT(F20)] eingegeben) und die einfache Eingabe der Zelle (anstelle [BadenWürtemberg] wurde von mir [F20] eingegeben) in der das Bundesland steht versucht, leider erfolglos.

    Ich hoffe das war soweit verständlich erklärt. [​IMG]

    Hat von Euch jemand eine Idee wie ich das eingeben muss/kann?

    Danke schonmal im Voraus!

    Gruß Volker
     
  2. VolkerMader Win User

    Nutzung von Variablen beim Zugriff auf Tabellen

    Hallo Claus,

    vielen vielen Danke!

    Deine Formel funktioniert wie gewünscht!

    Die Passage INDIREKT("Feiertage[[#Alle];["&$F$20&"]]") aus deiner Formel in meiner eingefügt hat auch das gewünschte Ergebniss gebracht.

    Da deine Formel jedoch etwas schlanker und unkomplizierter ist habe ich mich für diese entschieden. ;-)

    Nochmals recht herzlichen Dank!

    Gruß Volker
  3. Claus Busch Win User

    Nutzung von Variablen beim Zugriff auf Tabellen

    Hallo Volker,

    ich mag keine Tabellen und erst recht keine Tabellennamen in Formeln.

    Es geht daher noch etwas einfacher (ohne [#Alle]) entweder mit:

    =WENN(ZÄHLENWENN(INDIREKT("Feiertage["&$F$20&"]");F25)>0;7;J25)

    oder

    =MAX(J25;ISTZAHL(VERGLEICH(F25;INDIREKT("Feiertage["&$F$20&"]");0))*7)

    Claus
  4. VolkerMader Win User

    Nutzung von Variablen beim Zugriff auf Tabellen

    Hallo Claus,

    in F25 steht ein Datum, das findet er auch ohne Probleme in der Spalte meiner Tabelle für Baden Würtemberg und kann das auswerten.

    Ich habe jedoch das Problem, dass ich je nach eingabe des Bundesland in der zelle F20 in eine andere Spalte meiner Tabelle switchen will um dem Bundesland entsprechend die Feiertage aus zu wählen.

    Spalte J gibt eine Nummerierung 0-6 für die Wochentage des Datums in F aus.

    Die Spalte K gibt die Nummerierung der Wochentage aus, ausser wenn in dem in F20 angegebenen Bundesland ein Feiertag ist, dann wird die 7 ausgegeben.

    Momentan funktioniert das jedoch nur, wenn ich in der Formel der Spalte K, bei der Abfrage in der Tabelle die Überschrift für das entsprechende Bundesland per Hand eintrage (hier BadenWürtemberg).

    Gruß Volker


    [​IMG]
  5. Claus Busch Win User

    Nutzung von Variablen beim Zugriff auf Tabellen

    Hallo Volker,

    ich musste zuerst einmal schauen, was du mit dieser komplizierten Formel erreichen willst.

    Probiere es mal einfacher mit:

    =WENN(ZÄHLENWENN(INDIREKT("Feiertage[[#Alle];["&$F$20&"]]");F25)>0;7;J25)

    Claus
  6. Claus Busch Win User

    Nutzung von Variablen beim Zugriff auf Tabellen

    Hallo Volker,

    was steht in F25 und wie ist deine Tabelle Feiertage aufgebaut?

    Wenn in F25 ein Datum steht und die linke Spalte in Feiertage auch das Datum ist, probiere es mal mit:

    =INDEX(Feiertage[#Alle];VERGLEICH(F25;Feiertage[[#Alle];[Datum]];0);VERGLEICH(F20;Feiertage[#Kopfzeilen];0))

    Claus
  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

Nutzung von Variablen beim Zugriff auf Tabellen - Microsoft Office

Die Seite wird geladen...

Nutzung von Variablen beim Zugriff auf Tabellen - Similar Threads - Variablen Zugriff Tabellen

Forum Datum

sverweis mit mehreren Variablen

sverweis mit mehreren Variablen: Hallo zusammen, ich habe eine frage bezüglich dem SVERWEIS (wenn das überhaupt die richtige Funktion ist die ich benötige). Sicherlich ist die Frage schon X-Mal gestellt worden, lyncht mich...
Microsoft Office 27. September 2019

Variable Aufteilung eines Betrages

Variable Aufteilung eines Betrages: Ich habe eine Spielauswertung (Golf), wo z.B. bei 28 Spielern nur 12 Spieler den Cut geschafft haben, d. h. gleich oder besser als das Durchschnittsergebnis. Jetzt möchte ich den "Pott" variabel...
Microsoft Office 17. Oktober 2017

Nutzung

Nutzung: Hallo entstehen kosten für die Nutzung und was passiert wenn das Office abläuft kann ich die Daten weiternutzen?
Microsoft Office 13. September 2017

Variable in Formel einsetzen

Variable in Formel einsetzen: Hallo Community In Tabelle "Mitarbeiter" steht in B1 2017 und in C3 folgende Formel: =MAX('Jahr 2016'!Q6:'Jahr 2016'!AD6) zur Ermittlung des höchsten Datums in den Zellen Q6 bis AD6 der...
Microsoft Office 7. Februar 2017

Object Variable nicht festgelegt

Object Variable nicht festgelegt: Ich habe in einer AccessProzedur einen Befehl um eine pdf-Datei auszudrucken. Der Befehl funktioniert, wenn ich aber die Datei durch eine Variable ersetze in der die Datei gespeichert ist, dann...
Microsoft Office 26. Januar 2017

Excel - Variabler Dateinamen

Excel - Variabler Dateinamen: Hallo Ich habe eine Excel Tabelle in welche ich täglich Daten einlese. Wenn ich mit meiner Bearbeitung fertig bin und die Tabelle schließe - benenne ich diese dann manuell um. zB TabellenName...
Microsoft Office 22. Januar 2017

Fehlermeldung beim Zugriff auf Outlook.com

Fehlermeldung beim Zugriff auf Outlook.com: Dies ist die Fehlermeldung wenn ich mit dem IE meine Outlook öffnen will. [IMG] Was kann ich gegen diesen Meldung machen? Brauch Hilfe, dringend. Danke schon mal im Vorab zu den Kommentaren....
Outlook.com 1. November 2016
Nutzung von Variablen beim Zugriff auf Tabellen solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.