Sverweis und WENN

Diskutiere und helfe bei Sverweis und WENN im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo zusammen Hab es nun mit einigen Variationen versucht doch bin zu keinem grünen Zweig gekommen. Ich habe folgende Herausforderung. ich habe... Dieses Thema im Forum "Microsoft Office" wurde erstellt von Simona Ada, 11. November 2016.

  1. Simona Ada
    Simona Ada Gast

    Sverweis und WENN


    Hallo zusammen

    Hab es nun mit einigen Variationen versucht doch bin zu keinem grünen Zweig gekommen.

    Ich habe folgende Herausforderung.


    ich habe eine Tabelle (X)

    Nummer Version

    123456 A

    123455 B


    ich habe eine zweite Tabelle (XXX) mit den aktuellsten Daten

    Nummer Version

    123456 A

    123455 C


    Nun habe ich beim 1. Schritt folgendes gemacht.

    Ich wollte wissen ob die Nummer 123456 in der Tabelle XXX vorhanden ist, wenn ja hat er mir mit dem Sverweis die Information wiedergegeben. Das hat geklappt.


    Nun möchte ich die Information Version rausnehmen und zwar wie folgt:


    Wenn 123456 in der Tabelle X auch in der Tabelle XXX ist dann soll er kontrollieren ob dann die Version auch die aktuelle ist. Wenn ja dann kann er mir das anzeigen und wenn nicht darf es von mir aus auch N/V anzeigen.


    Ich hab es mit folgender Formel versucht.. :)

    =WENN(I1351 SVERWEIS(I1351;'[Doc from Tabelle.xlsx]doclink'!$A$2:$B$8595;2;FALSCH))+ WENN(H1351 SVERWEIS(H1351;'[Doc from Tabelle.xlsx]doclink'!$A$2:$B$8595;1;FALSCH));"SAME";"DIFFERENT")


    Hat natürlich nicht geklappt. Denke bin schon auf der richtigen Seite oder?

    Danke für eure Hilfe
     
  2. Andreas Killer Win User

    Suche einer Zahl innerhalb eines Bereiches

    Wie kann mir der sverweis ein nicht angegebener Wert in der Suchmatrix finden?
    Dazu musst Du die Daten aufsteigend nach "PLZ von" sortieren und Du lässt das Argument "Bereich_Verweis" bei SVERWEIS weg, z.B.:

    =SVERWEIS(5622;A:C;3)

    Dann sucht er nach dem Element >= dem Kriterium.

    Andreas.
  3. Claus Busch Win User

    Komplexe Formel?

    Hallo Monika,

    probiere es mal in F2 mit:

    =WENN(ODER(B2<SVERWEIS($A2;Tabelle2!$A$3:$I$50;2;0);B2>SVERWEIS($A2;Tabelle2!$A$3:$I$50;3;0));"Fehler Wert1";WENN(ODER(C2<SVERWEIS($A2;Tabelle2!$A$3:$I$50;4;0);B2>SVERWEIS($A2;Tabelle2!$A$3:$I$50;5;0));"Fehler Wert2";WENN(ODER(D2<SVERWEIS($A2;Tabelle2!$A$3:$I$50;6;0);D2>SVERWEIS($A2;Tabelle2!$A$3:$I$50;7;0));"Fehler
    Wert3";WENN(ODER(E2<SVERWEIS($A2;Tabelle2!$A$3:$I$50;8;0);E2>SVERWEIS($A2;Tabelle2!$A$3:$I$50;9;0));"Fehler Wert4";""))))

    Allerdings wird dir immer nur der erste gefundene Fehler angezeigt. Wird dieser behoben, wird der nächste angezeigt usw.

    Ich denke, dass du das besser mit VBA machen solltest.

    Claus
  4. Claus Busch Win User

    Hallo zusammen was könnte an dieser Formel falsch sein?

    Hallo Manuel,

    SVERWEIS übernimmt den Wert der Zelle und der ist 0, wenn die Zelle leer ist.

    Probiere es dann mal so:

    =WENNFEHLER(WENN(SVERWEIS(C12;'Bem. Alt'!$C$1:$AM$10000;37;0)=0;"";SVERWEIS(C12;'Bem. Alt'!$C$1:$AM$10000;37;0));"")

    Claus
  5. Claus Busch Win User

    Verkettete Wenn Funktion

    Hallo,

    probiers mal mit SVERWEIS:

    =SVERWEIS(E17;{-10000."--";-999."-";1."+";1000."++"};2;1)

    Mit freundlichen Grüßen

    Claus
  6. Claus Busch Win User

    SVERWIS abrunden in Excell 2007

    Hallo,



    ich weiß nicht wie deine Tabelle aussieht und kann deswegen nur schätzen.

    Wenn der erste SVERWEIS dir EUR bringt und der zweite den Betrag, dann versuch es mal so:

    =SVERWEIS(I31;I30:K31;2;0) & " " & RUNDEN(SVERWEIS(I31;I30:K31;3;0);2)



    Mit freundlichen Grüßen

    Claus
  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

Sverweis und WENN - Microsoft Office

Die Seite wird geladen...

Sverweis und WENN - Similar Threads - Sverweis

Forum Datum

Excel - Sverweise verketten? / Andere Formel?

Excel - Sverweise verketten? / Andere Formel?: Liebe Community, ich würde gerne eine Art Dienstplan im Excel erstellen, mit welchem ich einen schnellen Überblick behalte hinsichtlich Soll/Ist-Stunden pro MitarbeiterIn über´s Monat verteilt...
Microsoft Office Freitag um 09:22 Uhr

Excel - SVERWEIS

Excel - SVERWEIS: Hallo zusammen, eigentlich eine ganz klassische Aufgabenstellung für den SVERWEIS, aber ich bekomme immer den Fehler #BEZUG. Hier die Formel: =SVERWEISE525;Tabelle2!A2:A226;2;FALSCH Ich...
Microsoft Office 1. Mai 2020

Komplizierte SVERWEIS Formel

Komplizierte SVERWEIS Formel: =WENNSVERWEISH5;L2:M8;1;FALSCH=H5;SUMMESVERWEISH5;L2:M8;2;FALSCH;E6;SUMMESVERWEISH5;L15:M18;2;FALSCH;E7 Die Formel die ich dazu entwickelt habe sollte zuerst H5c zwischen L2 und M8 suchen und...
Microsoft Office 30. März 2020

ersatz für sverweis

ersatz für sverweis: hallo leute was kann ich statt sverweis verwenden damit ich bei der suche im Array die spalten nicht umorganisieren muss? suche von re. nach li. ich verwende Win 10; Excel MS home and students...
Microsoft Office 16. März 2020

Sverweis funktioniert nicht Fehler #NV obwohl Wert vorhanden

Sverweis funktioniert nicht Fehler #NV obwohl Wert vorhanden: Hallo zusammen, irgendwie scheint mein Sverweis nicht zu gehen... hier ein Beispiel: [IMG] Ich weiß ehrlich gesagt nicht woran es liegt.. ich zebrech' mir hier den Kopf. Kann mir hier jemand...
Microsoft Office 28. Januar 2020

SVerweis - #NV, obwohl die Tabelle den Wert enthält

SVerweis - #NV, obwohl die Tabelle den Wert enthält: Hallo zusammen, ich habe eine Tabelle, in der mehrere Maschinen aufgeführt sind. Mit einer Formel =D7*100/E7 berechne ich die Auslastung jeder Maschine. Mit der MAX-Formel lasse ich mir danach...
Microsoft Office 21. Januar 2020

SVerweis über zwei Sheets

SVerweis über zwei Sheets: Hallo liebe Community, ich komme leider nicht weiter und meine Excel Skills Stößen an ihre Grenzen. Folgende Situation: Ich habe eine Excel mit zwei Reitern (Tabelle1 und Tabelle2). In...
Microsoft Office 9. Dezember 2019
Sverweis und WENN solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.