Verschachtelte SVERWEIS für Staffelpreise

Diskutiere und helfe bei Verschachtelte SVERWEIS für Staffelpreise im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo, ich habe folgende Aufgabe: ich habe Tabelle mit unterschiedlichen Artikelnummer und Preisen je nach Menge. Artikelnummer ab Stück Preis ab... Dieses Thema im Forum "Microsoft Office" wurde erstellt von Daria_1510, 4. September 2019.

  1. Daria_1510
    Daria_1510 Gast

    Verschachtelte SVERWEIS für Staffelpreise


    Hallo,


    ich habe folgende Aufgabe:


    ich habe Tabelle mit unterschiedlichen Artikelnummer und Preisen je nach Menge.

    Artikelnummer ab Stück Preis ab Stück Preis ab Stück Preis
    55091113 1 50 € 5 45 € 20 40 €
    53000071 1 70 € 10 65 € 20 50 €

    Das Ziel ist:


    ich gebe in eine Zelle die Artikelnummer und in eine andere die Menge und Excel sucht nach dieser Nummer in der Tabelle und wählt mir den richtigen Preis anhand der Menge.


    Ich habe es fasst mit der SVERWEIS und WENN-Funktion statt Spaltenindex gelöst bekommen. Allerdings zieht Excel falsche Werte aus der Tabelle. Falschen Preis.



    So sieht meine Formel aus:

    =SVERWEIS(B3;Tabelle1!$AA$1:$AK$34;WENN($C3<AD2;"3";WENN($C3<AF2;"5";WENN($C3<AH2;"7";WENN($C3<AJ2;"9";WENN($C3>AJ2;"11")))));FALSCH)



    Kann mir jemand helfen, um festzustellen woran das Fehler liegt?

    Oder gibt es noch Möglichkeiten so eine Suche durchzuführen?



    Danke!
     
  2. IlirU Win User

    Verschachtelte SVERWEIS für Staffelpreise


    [​IMG]


    Hallo,

    Funktioniert diese Formel für Ihren Fall? (siehe Bild oben).

    =VERWEIS(J2;INDEX(B2:G100;VERGLEICH(I2;A2:A100;0);)*VORZEICHEN(B1:G1<>"Preis")-0,000000000001;INDEX(B2:G100;VERGLEICH(I2;A2:A100;0);)*VORZEICHEN(B1:G1="Preis"))

    Grüße,

  3. Claus Busch Win User

    Verschachtelte SVERWEIS für Staffelpreise

    Hallo Daria,

    erstens stehen die Vergleichswerte in einer anderen Tabelle und deswegen muss der Tabellenname vorgestellt werden, z.B. also

    WENN($C3<Tabelle1!AD" usw.

    Außerdem benötigst du für die Spaltennummern echte Zahlen und keine Texte. Entferne also die Anführungszeichen um die Spaltennummern.

    Da du aber für verschiedene Artikel verschiedene Staffelungen hast, musst du für jeden Artikel eine neue Formel entwickeln. Besser wäre es, wenn du die Vergleichstabelle anders anordnen würdest, dann kann man mit einem einfachen SVERWEIS den Preis aus der
    Tabelle nehmen, egal wie die Staffelung für diesen Artikel gestaltet ist.

    Schau dazu mal hier rein:

    https://1drv.ms/x/s!AqMiGBK2qniTgeYBioZt2A6UPo-M4w?e=gXHYwF

    Claus
  4. JulianZimmermann Win User

    zwei-dimensionaler Verweis für Fortgeschrittene

    Hallo Claus,

    vielen Dank aber ich will erstmal noch versuchen das Ohne VBA zu machen, rein mit Excelbefehlen. Geht das nicht?

    Ein anderer Ansatz: Könnte man nicht theoretisch mit einem verschachtelten SVERWEIS arbeiten?

    Suche in der großen Matrix (der Gesamttabelle) die Rechnungsnummer. Von da aus ist die Rechnungsnummer eine neue A1 einer neuen Matrix, in der ein SVERWEIS nach dem Posten sucht und den Wert im Spaltenindex 2 auswirft.

    Beste Grüße,

    Julian
  5. Claus Busch Win User

    Wenn dann oder wenn dann oder ...

    Hallo Lisa,

    probiere es mal so:

    =WENNFEHLER(SVERWEIS(A1;{"ja".6;"nein".5};2;0);"")

    Damit wird auch ein Fehler abgefangen, wenn etwas anderes als ja oder nein in der Zelle steht.

    Als verschachtelte WENN-Formel:

    =WENN(A1="ja";6;WENN(A1="nein";5;""))

    Claus
  6. Claus Busch Win User

    Formel wirft eine Fehlermeldung aus

    Hallo Klaus,

    in deiner Reihe fehlt die 91 und dies ergibt einen Fehler. Außerdem brauchst du nur einfache Anführungszeichen.

    Ändere also auf:

    =WENN(L2<51;"nicht bestanden";WENN(L2<67;"bestanden";WENN(L2<81;"gut";WENN(L2<=91;"sehr gut";WENN(L2>91;"vorzüglich")))))

    Ich würde SVERWEIS der verschachtelten WENN-Formel vorziehen:

    =SVERWEIS(L2;{0."nicht bestanden";51."bestanden";67."gut";81."sehr gut";92."vorzüglich"};2;1)

    Claus
  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

Verschachtelte SVERWEIS für Staffelpreise - Microsoft Office

Die Seite wird geladen...

Verschachtelte SVERWEIS für Staffelpreise - Similar Threads - Verschachtelte SVERWEIS Staffelpreise

Forum Datum

SVerweis

SVerweis: Hallo zusammen, ich habe folgendes Problem: ich habe als Matrix eine Reference Nummer die aber entweder im Spaltenindex A oder B in meiner Pivot Tabelle zu finden ist. Ich möchte also sagen...
Microsoft Office 11. September 2019

SVERWEIS Limit

SVERWEIS Limit: Hallo zusammen, ich habe hier eine Tabelle, bei welcher ich die Sverweis-Formel anwende. Diese ist auch korrekt, daran ist kein Zweifel. Nur funktioniert diese Formel nur bis paar hundert...
Microsoft Office 7. Februar 2019

Sverweis

Sverweis: Guten Tag, Ich habe einen Sverweis installiert mit unseren Artikelnummern welche aus 4 Stellen nach dem Komma bestehen. Wenn ich nun einen Artikel mit einer "0" am Ende eingebe z.B. 11.1110...
Microsoft Office 21. August 2018

Mehrfacher SVERWEIS

Mehrfacher SVERWEIS: Hallo, Ich habe eine Adressdatei mit Name, Vorname usw.. aus der ich in einem Tabellenblatt bestimmte Daten anhand des Suchbegriffs NAME zusammenstellen möchte. Nun gibt es aber Dubletten, d.h....
Microsoft Office 3. Mai 2018

Sverweis

Sverweis: Aufgabe: Nettoeinkaufspreis pro Stück des Produkts ermitteln, welches in der Verkaufstransaktion mit dem höchsten maximalen Einzelgewinn verkauft wurde. [IMG][IMG] Ich habe nun für diese...
Microsoft Office 20. Dezember 2017

SVerweis

SVerweis: was ist falsch =SVERWEIS(AB2;Tabelle2!A$1:B$6;2;FALSCH) in AB2 steht eine Zahl trotzdem erscheint #NV
Microsoft Office 20. Oktober 2017

SVERWEIS

SVERWEIS: Hallo zusammen, ich habe eine Frage, welche eigentlich gar nicht sein sollte. ich habe in einer Spalte die Zahlen 1 bis 1000 fortlaufend gelistet und auf der Spalte nebenan deren Gruppe. Also z.B....
Microsoft Office 17. Oktober 2017
Verschachtelte SVERWEIS für Staffelpreise solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.