Verschachtelung mehrerer WENNUND.. Funktionen

Diskutiere und helfe bei Verschachtelung mehrerer WENNUND.. Funktionen im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo Forenmitglieder, ich möchte eine dynamische Ausgabe des Minimal- und Maximalwertes einer Datentabelle aufbauen. Die Tabellenaufteilung schaut... Dieses Thema im Forum "Microsoft Office" wurde erstellt von D_ustin, 8. April 2021.

  1. D_ustin
    D_ustin Gast

    Verschachtelung mehrerer WENNUND.. Funktionen


    Hallo Forenmitglieder,


    ich möchte eine dynamische Ausgabe des Minimal- und Maximalwertes einer Datentabelle aufbauen. Die Tabellenaufteilung schaut dabei wie folgt aus:


    Datum Reihe 1 Reihe 2 Min Max


    Die Daten sind in einer Tabelle formatiert und Ziel ist es, für die jeweils aktive Reihe 1 oder 2 den Minimal- resp. Maximalwert auszugeben. Damit der Wert nur für den Datumsabschnitt ausgewählt wird muss natürlich TEILERGEBNIS. verwendet werden. Die Reihendaten für Reihe 1 und 2 sind dabei an eine Liste geknüpft, sodass Reihe 1 aktiv ist wenn Reihe 1 in der Dropdown-Liste ausgewählt wurde und vice versa.

    Zu prüfen ist für den Befehl dabei folgendes:

    Wurde Reihe 1 ausgewählt und ist der Zeilenwert das Minima des aktiven Teils der Reihe? Dann gib diesen Wert aus. Anderenfalls prüfe ob Reihe 2 aktiv ist und der Zeilenwert das Minima des aktiven Teils von Reihe 2 ist. Wenn ja gib diesen Wert aus. Wenn nein #NV.


    Mein Versuch schaut wie folgt aus:

    =WENNUNDManip[[#Kopfzeilen];[Reihe 1]]=Tabelle1!$B$1; [@Reihe 1]=TEILERGEBNIS5; [Reihe 1]; [@Reihe 1]; WENNUNDManip[[#Kopfzeilen];[Reihe 2]]=Tabelle1!$B$1; [@[Reihe 2]]=TEILERGEBNIS5; [Reihe 2]; [@[Reihe 2]]; NV


    Im Ergebnis zeigt er korrekterweise für alle aktiven Reihendaten von Reihe 1 den Minimalwert an, jedoch funktioniert das nicht für Reihe 2. Dort steht immer nur #NV, obwohl der zweite Teil aus meiner Sicht mit der Prüfung des ersten Teils doch identisch ist. Also wenn Reihe 2 aktiv ist, dann erkennt er keinen Minimalwert obwohl dieser klar existiert und für sich alleinstehend der zweite Teil der Abfrage diesen auch erkennt.


    Kann hier jemand eine Hiflstellung geben, weshalb beide Abfragen für sich alleinstehend das richtige Ergebnis liefern, die Verschachtelung der WENNUND-Funktionen miteinander jedoch für die zweite zu untersuchende Reihe eine Fehlermeldung liefert?


    Liebe Grüße


    D_ustin
     
  2. Notebook-PC Ben brau Win User

    Funktion WENN mehrere verschachtelungen erstellen?!

    Danke für deine Hilfe

    Mit freundlichen Grüßen

    Ben
  3. Claus Busch Win User

    Funktion WENN mehrere verschachtelungen erstellen?!

    Hallo Ben,

    mache dir z.B. in I1:J9 deine Tabelle mit den Abstufungen, also I1=0, J1 = 4 usw.

    Jetzt kannst du in A1 deinen Wert eingeben und schreibst dann in B1:

    =SVERWEIS(A1;$I$1:$J$9;2;1)

    Mit freundlichen Grüßen

  4. Andreas Killer Win User

    Funktion WENN mehrere verschachtelungen erstellen?!

    Das kann man mit INDEX und VERGLEICH auch machen.



    =INDEX({"-";"a";"b";"c";"-"};VERGLEICH(A1;{0;1;2;3;4}))

    Das liefert für 1 ein a, 2 ein b, 3 ein c und alles andere einen Strich.

    Andreas.
  5. Notebook-PC Ben brau Win User

    Funktion WENN mehrere verschachtelungen erstellen?!

    jaa danke dir, nur hab ich jetzt das problem wenn ich in A1 jetzt keine zahl drin habe bleibt in B1 die zahl da drin stehn, was eig. nicht sein sollte. Wie kann man es dann machen wenn in A1 keine Zahl drin steht das dann auch in B1 dann auch keine zahl
    drin steht also einfach dann auch ein leere zelle entsteht?
  6. Claus Busch Win User

    Funktion WENN mehrere verschachtelungen erstellen?!

    Hallo,

    =WENN(A1="";"";SVERWEIS(A1;$I$1:$J$9;2;1))

    Mit freundlichen Grüßen

  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

Verschachtelung mehrerer WENNUND.. Funktionen - Microsoft Office

Die Seite wird geladen...

Verschachtelung mehrerer WENNUND.. Funktionen - Similar Threads - Verschachtelung mehrerer WENNUND

Forum Datum

IF Verschachtelung mit Berechnungen

IF Verschachtelung mit Berechnungen: Liebe Community, ich hoffe ihr könnt mir weiterhelfen bei meinem Problem. ich habe eine kleine Tabelle in ein Word Dokument eingefügt. Da sollen in der letzten Spalte die Abweichungen von den...
Microsoft Office 15. Januar 2021

OneNote hat nicht mehr alle Funktionen

OneNote hat nicht mehr alle Funktionen: Hallo, vor ein paar Tagen hat sich mein OneNote im Ladebildschirm festgesetzt. Es lädt und lädt und lädt, aber es ist nichts passiert. Also habe ich es deinstalliert und neu installiert...
Microsoft Office 16. November 2020

Funktion mit mehreren Suchkriterien

Funktion mit mehreren Suchkriterien: Hallo, ich möchte auf einer Tabellen-Zeile unterschiedliche Buchstaben a, f, k, ü, addieren. Leider bekomme ich immer wieder Wert! angezeigt. Meine Frage: Welche Formel wende ich dafür an?...
Microsoft Office 30. September 2020

Keine Funktion der Spiele mehr

Keine Funktion der Spiele mehr: Hallo! Gestern mußte angeblich der rechner ein Laufwerk prüfen und reparieren, dann hatte ich plötzlich auch noch ein Update für die Grafikkarte von Nvidia. Ein neuer Treiber . Jetzt...
Allgemeines 23. Februar 2019

mehrere Wenn Und Funktionen in einer Zelle

mehrere Wenn Und Funktionen in einer Zelle: Hallo, ich habe mir eine kleine Lottoübersicht erstellt. Spalte A = Gewinnklasse (nach unten 1bis 12) Spalte B = Richtige von 50 (nach unten anhand Quotenverteilung) Spalte C = Richtige von...
Microsoft Office 18. Februar 2018

Nach Update keine Funktionen mehr

Nach Update keine Funktionen mehr: Hallo allerseits, nach dem letzten Update funktioniert bei mit Office 2016 nicht mehr. Angeblich muss ich die Apps aktivieren, was nicht funktioniert und bei Word wird angezeigt, das word nur im...
Microsoft Office 17. November 2017

Keine Funktion mehr

Keine Funktion mehr: Habe jetzt das neue Update auf mein Lumia 950xl aufgespielt. Seid dem kann ich weder Office noch was andere. Er erkennt das die Datei vorhanden ist abe kann nichts öffnen. Habe Office schon...
Microsoft Office 29. Mai 2017
Verschachtelung mehrerer WENNUND.. Funktionen solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.