ZÄHLENWENN setzt sich in Tabelle falsch weiter

Diskutiere und helfe bei ZÄHLENWENN setzt sich in Tabelle falsch weiter im Bereich Microsoft Office im Windows Info bei einer Lösung; Hallo, ich möchte gerade eine Excel erstellen um meine Stunden aufzuschreiben, die ich für gewisse Projekte arbeite. Momentan sieht das ganze so aus:... Dieses Thema im Forum "Microsoft Office" wurde erstellt von Laura168, 7. August 2019.

  1. Laura168
    Laura168 Gast

    ZÄHLENWENN setzt sich in Tabelle falsch weiter


    Hallo,


    ich möchte gerade eine Excel erstellen um meine Stunden aufzuschreiben, die ich für gewisse Projekte arbeite. Momentan sieht das ganze so aus:

    [​IMG]


    Der Einfachheit habe ich mal ein paar Zeilen ausgeblendet. Wenn ich jetzt unten in der Tabelle ein neues Projekt hinzufüge, führt sich der 'Zählewenn' Befehl leider nicht so fort, wie ich das gerne hätte. Es sollen weiterhin nur die Zellen (D4:34) betrachtet werden. Leider verschiebt sich die Funktion aber auf (D5:D35).


    Kann mir jemand helfen? Vielen Dank schonmal!


    Liebe Grüße,

    Laura
     
  2. Claus Busch Win User

    Exel

    Hallo,

    dazu müsstest du VBA verwenden. Was ist grün? Die Schriftfarbe oder der Hintergrund?

    Einfacher wäre es zu erreichen mit ZÄHLENWENN. Wenn du für "krank" ein "k" eingibst, könntest du zählen mit z.B.:

    =ZÄHLENWENN(D:D;"k")

    Je nach Aufbau deiner Tabelle könntest du auch eine Pivot-Tabelle zur Auswertung erstellen.

    Claus
  3. Dura Cell Win User

    ZÄHLENWENNS kombinieren

    Hallo Claus,

    zunächst schicke ich mal ein Danke voraus. Die Formel erzeugte bei mir einen Fehler. Aber alles halb so schlimm.

    Beispieldatei

    Ich habe aus meiner Arbeitsdatei alle vertraulichen und für die Aufgabenstellung irrelevanten Inhalte gelöscht. Spalten wurden nicht entfernt. Eine kleine Vorwarnung. Die Obergrenze von 5 MB für Excel Online wurde überschritten. Daher musst Du sie mit Excel
    öffnen.

    Und nun zurück zu deiner Formel. Du hast Dich für die Funktion SUMME entschieden. Wieso SUMME? Die SUMME-Funktion findet ja eher zum summieren von Zellbereichen seine Anwendung. Mein Gedankengang war ein anderer. Falls meine Herangehensweise falsch ist,
    kannst Du vielleicht die losen Enden verknüpfen. An sich möchte ich einen Zellbezug in Tabelle 1 unter gewissen Bedingungen mit Tabelle 2 abgleichen. Und ob die Bedingungen zutreffen oder nicht soll mit WAHR oder FALSCH beantwortet werden. Solche Resultate
    werden von der WENN-Funktion wiedergegeben. Da die Funktion WENN jedoch nur eine Bedingung überprüfen kann, griff ich zur Funktion ZÄHLENWENNS. ZÄHLENWENNS gibt zwar kein WAHR oder FALSCH zurück, war meinem Verständnis nach das naheliegendste.

    Was mir bei Deiner Formel nicht klar ist, sind die Multiplikatoren. Wieso Mal?

    Wäre nett von Dir, wenn Du mal einen Blick in meine Beispieldatei werfen würdest. Und vielleicht kannst Du auch etwas zu meinem Gedankengang sagen. Richtig oder falsch? Wenn Falsch, was. Mein Bestreben ist ja nicht nur, andere um Hilfe zu bitten, sondern
    auch etwas dabei zu lernen.
  4. Andreas Killer Win User

    Excel Formel - ich verzweifle ...

    Genau, mach Dir eine Hilfsspalte mit der Formel

    =ZÄHLENWENN(R:R;R2)

    und runterziehen.

    Dann setzt Du einen Autofilter und filterst diese Spalte Zahlen >= 10

    Dann markierst Du alle Datenzellen in Spalte, tippst ein "x" in die Bearbeitungsleiste und drück STRG-ENTER

    Andreas.
  5. Claus Busch Win User

    eMail-Listeneinträge zählen und auswerten

    Hallo,

    gehe auf Daten => Filtern und Sortieren => Erweitert => Liste an eine andere Stelle kopieren => Listenbereich B:B => Kopieren nach E1 und "Keine Duplikate" aktivieren. Dafür sollte deine Tabelle in A und B aber Überschriften haben.

    ZÄHLENWENN verlangt 2 Argumente, zuerst den Bereich, in dem gezählt werden soll und als zweites Argument was gezählt werden soll.

    In meiner Tabelle ist das dann E2 und die Formel lautet dann:

    =ZÄHLENWENN(A:A;"*"&E2)

    Du kannst aber auch die einheitlichen Domains in B zählen mit

    =ZÄHLENWENN(B:B;E2)

    Claus
  6. Claus Busch Win User

    SVerweis - Matrix - Zeilen limitiert?

    Hallo Christiane,

    ich kann das nicht nachvollziehen. Bei mir geht es auch, wenn ich die letzte Zelle eingebe:

    =SVERWEIS(E2;$G$2:$H$1048576;2;FALSCH)

    Aber warum willst du den Wert aus Spalte H ausgegeben haben, wenn du nur auf Duplikate testen willst? Das würde einfacher gehen, wenn du das mit ZÄHLENWENN durchführen würdest.

    Beschreibe mal den Tabellenaufbau der beiden Tabellen und welche Spalte du in beiden nach Duplikaten durchsuchen möchtest.

    Claus
  7. User Advert


    Hi,

    willkommen im Windows Forum!
Thema:

ZÄHLENWENN setzt sich in Tabelle falsch weiter - Microsoft Office

Die Seite wird geladen...

ZÄHLENWENN setzt sich in Tabelle falsch weiter - Similar Threads - ZÄHLENWENN Tabelle falsch

Forum Datum

Zählenwenn im oder mit Datumfeld

Zählenwenn im oder mit Datumfeld: Ich möchte in der Tabelle1 die Spalte [PostDatum] zählen, wenn das Datum <= Heute (Aktuelles Datum) ist. Wo liegt der Fehler in dieser Formel. =ZÄHLENWENN(Tabelle1[PostDatum];"<=HEUTE()") Ich...
Microsoft Office 16. April 2019

ZÄHLENWENNS mit Formaten

ZÄHLENWENNS mit Formaten: Guten Tag, ist es möglich, mit der Funktion ZÄHLENWENNS nicht nur die Anzahl der Zellen mit definierten Werten, sondern auch Anzahl der Zellen mit definierten Zellformaten zu zählen, und wenn,...
Microsoft Office 8. Februar 2019

ZÄHLENWENNS kombinieren

ZÄHLENWENNS kombinieren: Ich habe eine Materialliste. Ich hätte ein Beispiel angehängt, wenn ich die Funktion gefunden hätte. Ich schildere mein Problem. Tabelle 1 enthält alle existenten Materialnummer (Spalte A). In...
Microsoft Office 6. September 2018

ZÄHLENWENNS und #WERT

ZÄHLENWENNS und #WERT: Hallo! Immer wenn ich die Formel ZÄHLENWENNS(A:B;X;C:D;Y) eingebe, kommt bei mir die Angabe #WERT. Ich habe schon überprüft, ob Leerzeichen vorliegen, was nich der Fall ist. Auch ist das File...
Microsoft Office 20. Januar 2018

Excel - Zählenwenn liefert falsches Ergebnis

Excel - Zählenwenn liefert falsches Ergebnis: Ich habe mit Excel eine Zählenwenn-Funktion genutzt, allerdings werden mir falsche Ergebnisse geliefert. Der Wert ist definitiv nur einmal vorhanden, die Zählenwenn-Funktion gibt aber "2" aus....
Microsoft Office 15. August 2017

ZÄHLENWENN mit Kriterien aus einer Spalte

ZÄHLENWENN mit Kriterien aus einer Spalte: Hallo, Ich habe einen Tabellenbereich U2:X21, in dem ich das Vorkommen jedes Begriffes zählen möchte, der in der Spalte AA1 steht. Also wenn z.B. im o.a. Bereich Namen stehen (Schmidt, Meier,...
Microsoft Office 14. Januar 2017

Problem mit Zählenwenns()

Problem mit Zählenwenns(): Hallo zusammen! Ich habe eine Liste, in der die Teilnahme an einer Sitzung sowie die Abgabe einer Arbeit gezählt werden soll. Teilgenommen bzw. abgegeben werden mit einer 1, nicht teilgenommen...
Microsoft Office 25. Oktober 2016
ZÄHLENWENN setzt sich in Tabelle falsch weiter solved
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.